write ahead log

ロールフォワード用

Laravelでcomposer使うとやたらIt is unsafe to run Dusk in production.と言われる時の対処

なんか前も同じ事やった気がするのでメモっとく.

composer installとかcomposer updateをすると以下のメッセージが出てくる.

It is unsafe to run Dusk in production.

本番環境でDusk入れるなあぶねーぞだそうだ.うん.そうだね.

対処

composer.jsonに以下を追記した.

     "extra": {
         "laravel": {
             "dont-discover": [
+                               "laravel/dusk"
             ]
         }
     },

昔見た時にはrequire-devへduskの記述を書けばよいってのがあった気がするんだけど.(っていうか名前的にそうじゃね?)

require-devでもどうにも現象が収まらなかったので上記で解決した.